Did MIRO update the way permissions work? Getting a Insufficient permissions error with out code change

  • 20 January 2023
  • 2 replies
  • 17 views

Badge +1

Had configured our app to create boards from other boards (by copying them), and suddenly it stop working
This is our flow, we call : "https://api.miro.com/v1/oauth/token?grant_type=authorization_code"
Then we call:
url = URI("https://api.miro.com/v2/boards?copy_from=#{template_id}")
And we are getting this error

"Full body {\"type\"=>\"error\", \"code\"=>\"4.0602\", \"context\"=>{\"boardId\"=>\"xxxxx=\"}, \"message\"=>\"Insufficient permissions to perform operation. Please check the permissions or contact support\", \"status\"=>403}"

Permissions have not been changed in months

App has permissions to read / write and original board has view permissions for every one, this error started appearing jus a few weeks ago.


2 replies

Userlevel 5
Badge +3

Hey @Carlos López,

Thanks for reaching out about this. If you haven’t made any changes on your end, I agree that it seems strange. Have you tried regenerating the access_token you’re using by chance?

If you’ve already tried this, can I kindly ask that you open up a request with our Support team and share the full details of the board IDs with them? They should be able to take a closer look at the boards and further investigate why you’re getting a permissions error.

Thanks!

Badge +1

We haven’t regenerated the access token, because this works within our team, it’s user outside our team that are having problems, but that did not happen before.

Already opened a request with support, thank you.

Reply