A spcific Board no longer loads, neither in browser or the app. Other boards load


A specific Board no longer loads, neither in browser or the app. Other boards load.


I need access to it asap and can’t find anyone to chat to.

3 replies

Userlevel 7
Badge +12

@Vero Schmidt - Here are a canned response with a few things to try:

Here are things to try.

  • If you are using a browser to access Miro:
    • Sign out and back in (a code change may have been pushed and needs to be picked up)
    • clear the cache
    • disable all extensions (opening an incognito/private browser window usually takes care of this for you)
    • Try a different browser
    • Try the Miro desktop app
  • If using the Miro desktop app, reset the application data.

If none of that works, please share a screenshot of what you are seeing. A screen recording is even better - Loom is free and easy to use/share a video.

Can you try from a different device/computer?

Does it happen for any other board participants?

What happens if you duplicate the board?

Is the board shared with others? If so, what happens if you make the board private and share it again? (Only an option if you are the board owner, and the board is not in a free plan.)

If you are on a paid plan, you can also report this directly to the Miro support team - instructions can be found here → https://help.miro.com/hc/en-us/articles/360020185799-How-to-contact-Miro-Support#h_01F010RXA0E1S9C0WFQYX75R6C  


My developer has tried too, he’s in a different office, we both have the same. I have tried on App and browser. Other boards work.

We have also tried upgrading our account today, but that was after which also failed it seems. So right now I don’t think I can access the support yet.

However, it has just started working for me...

Userlevel 7
Badge +12

@Vero Schmidt 

However, it has just started working for me…

Frustrating, buy yay!