Miro shows an endless loading screen

Can’t open any Miro boards

I’ve already tried:

  • clearing cache and browser history
  • using incognito mode
  • using different browser
  • restarting browser
  • restarting my computer

Nothing seems to help :(

I can’t use the desktop version as well. Are there any other possible solutions for this problem?

12 replies

Userlevel 6
Badge +1

Hey @Liya,

Sorry to hear you ran into this issue 😔

I've converted your post to the support ticket and reached out to you there, asking to provide some additional details for us to investigate the issue further. 

@Liya Did you find a fix for this? I am experiencing this as well!


@Sammy22 hi!

Not yet, but the issue is passed along to the technical support and I was assured that I will get futher information as soon as possible. So, when technical support teams comes back with a solution I'll share with you all the information

@Alyona I’ve also been experiencing this all day, any suggestions?

Userlevel 6
Badge +1

Hi @Sammy22, @MonicaR,

I'm sorry to hear you are now facing this issue too 😟

Could you please check how the problematic boards are loading if you were to open them on the mobile device using a cellular network (either via the mobile app or in any browser)? In case the boards can be loaded there, please restart your router or modem and try opening the board on your PC again.

Please let me know how it goes!

I have the same issue and it is not resolving after many months! can only use it on my phone.
How am I suppose to work like that it is very disturbing and i see many people has the same issue…

If anyone has found a solution please let me know.

I have followed all instructions  and same as @Liya …


Please help

Userlevel 7
Badge +6

@Íñigo Muñoz Bilbao -

Make sure your browser is supported as per this article: https://help.miro.com/hc/en-us/articles/360017572814-Supported-browsers-browser-restrictions

You can also try disabling any/all browser extensions to make sure there isn’t a conflict with one of those

Finally, make sure that there isn’t a firewall or VPN-related port blocking issue on your side.


Going through this now.. nothing anybody mentioned here helped. It works fine on my phone (using the exact same Internet connection), but it refuses to work on my main work Mac. Re-installed, restarted many times, updated Mac OS, cleaned the Miro cache, tried to run it in 4(!) different browsers, the Miro App for M1 macs, etc. Everything else on my Mac works fine, internet works like a charm, no VPN running, no firewall warnings, nothing. Already lost 3 hours of work. On average, Miro makes me waste 1 hour for every 4 hours worked due to technical BS. Am beyond angry, but have no choice but endure using it because my clients get conned into buying into the promise of fantastic collaboration and efficiency gains. It’s now a running gag amongst all the freelancers in my network. But here I am, again suffering through another trouble shooting session… Please fix this ongoing mess of a technical implementation.

Userlevel 3

On my iPad I can load the boards, but on my Windows computer, I get an endless loading screen, too.

Both devices use the same internet connection.

Yeah, it seems this happens randomly to everyone I know that uses Miro. The error messaging is non-existent, so we’re left guessing in regards to what’s going on. Today it’s working for me, without a clear reason why. It’s nothing I did, so probably just a service issue on Miro’s side.

I am having this issue right now on Chrome browser. Tried both Google and login/password auth. Getting permanent loading screen.

Any update on the issue or its work-around?


After updating Chrome to the newerst version the issue is gone.