[KNOWN BUG] Apple iPad Pro - Pencil

  • 24 November 2022
  • 39 replies

Userlevel 1

I am testing this app for the business. on a new iPad Pro using the Miro app from the Apple store.  When I select the pen icon from the tool bar and then start to write or draw and object the moment my pen is no longer in contact with the screen what I have drawn disappears.  I can create a object or a text box and write in them, but on the “open” area of the whiteboard nothing.  I have installed the MS white board and there is no issue with the pen in that application. Seems like I am missing a setting. Can someone give me a hand?

Arin 1 year ago

Hi @Rob DeMars!​
Thank you for getting in touch! We fully understand the impact that this issue might have on Miro users. We are truly sorry for any inconvenience this might have caused. 

Our developers have recently released a pack of improvements for Apple Pen performance, so hopefully, this will help with some of our users with issues related to the Apple Pen. We have been receiving confirmations from other customers who reported similar difficulties that things have been smooth for them. However,  the release was not specifically for new iPad Pro users but we assume this might help with most cases.

To that end, please ensure that you're using the latest version of the app and let us know if there’s been any sort of improvements. 

Thanks again for your patience!

View original

39 replies


I downloaded the Miro App yesterday with my new iPad Pro and the pencil doesn’t work. 

This will become a problem very soon.    


Just got a new iPad Pro M2. Facing similar problem. Pencil was drawing fine then suddenly stopped working. I see it draw then it disappears. Has anyone figured out how to work around this issue? 

Hi. I’m in the same position as many other people. Just bought an iPad pro with pencil. Miro seems great but with the pencil not working on the app it’s really frustrating.

Also experiencing this - it’s very frustrating as I solely use the ipad when working away from home. 

Today it got even worse... All week when there was a problem, I rebooted the application, the pencil worked correctly. Today he does not draw at all, he immediately deletes your drawing.

Issue persists - what is the outlook… it is extremely frustrating!

Still broken for me. Would be very cool to get this fixed.

Same issue still happening for me

Same issue.  New iPad Pro with Apple Pencil.  Weirdly, it just started not working like 3 days ago.  It was working fine for like 2 weeks.  So frustrating given the world has moved remote and this is our collaboration software!  

Any news? The pencil is still not working here. Super frustrating!!

1 month on and still an issue 😔 Are there any updates?

Out of a sudden my pen seems to be working now.

Fingers crossed it stays like that.

Userlevel 1

@Arin This issue appears to be resolved:)

Is this fixed? Cause its not fixed for me.