Blurry images

  • 25 August 2020
  • 36 replies

Userlevel 1

Some PDFs and JPEGs which are 300 or sometimes 600px resolution that I upload are blurry at any magnification. What to do? : )


Best answer by Kiron Bondale 25 August 2020, 22:36

View original

36 replies

Userlevel 4

Hi @Cathline Marshall 

You probably need to say a bit more if a solution is to be forthcoming

If i drop a pdf on a board there are 2 dynamics - how big I expand it to be by resizing using a drag on the corners and the zoom level of the board.

In all cases I can resize and zoom in to the point where i get a super sharp result. At 400% I can resize the pdf down to illegible but I can resize up to sharp - pretty much the same at 1%

a pdf will be different to a jpg as pdf will always have potential to render sharp. With a jpg that has a sharp render at some balance i can get sharp results all the way from 1% to 400% 

Works in the app and a browser for me

Obviously your milage is varying - perhaps you can explain a little more 

Userlevel 1

@Simon.Harris Thanks for getting back to me. I noticed on some of my colleague's boards as well that the images are blurry at any magnification. I will figure it out! Thanks again.


Userlevel 7
Badge +6

@Cathline Marshall & @Simon.Harris -

There might also be occasional latency in rendering detailed images - for example, there were some performance “hiccups” this morning which led to certain images in one of my boards remaining blurry for a while but the loading “meter” (the blue circle) did show up when that happened so I knew they were still rendering.

If this is happening ALL the time, that definitely sounds like a support call might be in order...


Userlevel 1

@Kiron Bondale Thanks for your note! Will do.



Maybe there is an answer to this already - but should I really create all powerpoints to PDF before I can actually read the slides in MIRO? - Another way of asking: is there any way I can improve the slide quality when copy/pasting directly?


Userlevel 1

I am using MIRO with my new Macbook Pro and Big Sur. Whether I use the on-line Chrome version or the desktop version, my images are showing up blurry. I am using PPT slides, positioning them, and making notes. When I place them, they are clear as a bell. When I come back after closing and re-opening the application they are blurry. I don’t think it is a latency problem; no amount of waiting seems to change the result. I am not getting a little blue circle either. What’s happening? How can I correct it? I have done a “Refresh Current Tab” with no change. I can re-insert a ppt slide that is perfectly clear, come back awhile later, and it will be blurry as well. 

Userlevel 1

I still haven’t figured out an answer, Ed. Still often have the same problem. Miro, can you please chime in?

Thank you.



Userlevel 1

Thanks Cathline.



I have the same problem as described by @Ed Zinkiewicz.

I have the same issues as well



I have the same issue since this morning when pasting PowerPoint Slides. It has not happened before but now nothing seems to fix the blurriness.

Same here.  Put PDFs of slides in yesterday evening, looked fine - high res & crispy.  This morning they are burry even after a refresh tab.  Working off the app on MacBook Pro using 10.15.7 (19H524).  I get latency but this has been 15 minutes now.

I have a workshop today with clients, and it would be lovely to have something to tell them when the slides don’t resolve for them - this thread seems to suggest there is nothing.  

I literally can not read text.

Feature request: Contextual menu selection that allows one to refresh just the import highlighted (bonus: multiple at a time).  Or just fix the latency (is it latency if it never seems to resolve?)

same issue this morning. please advise...

OK, after quite a bit of fiddling, I have determined that the workaround is to zoom the __ in - like to see only 1/4th of the slide in my full window, and it will then properly resolve/load up.  At least now I know what to tell the clients if they can’t read the slides.

@Miro, the issue is that if I load up a board and it includes PDFs that take up a portion of the window, Miro is set to only serve up a low res - FPO? image, requiring me to zoom in WAY too much in order to get the full resolution to load up.  

I understand the idea of serving up only what is needed, but these - break points? are set completely wrong for me.  Let’s please remember we all now have high speed internet - this seems set at “Mid 90s DSL internet as seen on a VGA display” when I have Gig and a 4k.  Literally not serving them up so they can be read (until after zooming in, then fine).  This should be enough to make it very clear what the issue is, and I would be happy to provide any other information in order to make this “real” for Miro’s support and thus get this into the pipeline for a fix.

… The issue of blurriness when pasting Powerpoint slides persists (for me at least). 

Has anyone found a solution besides pasting from PDF versions?

Same problem. I don’t know if this is solved elsewhere, but would be great to include a solution on this thread which is the first google hit for this issue.

It seems this is a recent problem. Two months back, I could infinitely zoom into a vectorized pdf or svg without any issues.

You can try upload as jpg, png or screenshots copy see if it works. 

I’m also having blurry images on MacBook Pro, using the app. Makes Miro quite unusable :(

Same problem here on the iPad either in the app or the web. 

Users on i pad are reporting same problem here also.

Having the same issue. Dissapointed that this hasn’t been addressed

Userlevel 1

I have the same issue: pdf looks like this:


Is there any reaction on this issue? This is my first task on Miro ever and I’m about to shut it down forever… 


I’m having the same issue here as of yesterday. Blurry PDF’s that also make the navigation on Miro board jagged and jumpy, smooth zoom and pan is lost. If I delete the PDF it reverts to smooth navigation again. Perhaps another post about this. 


I thought it was at the Software Authoring the PDF (ArchiCAD) but other pdf’s from there are fine. I tried the Open in Preview export as PDF option too to re-author it but this same pdf still gives issues. 

May try PDF to SVG vector as workaround in InkScape.