The Submit Button on "Apply for a free Education account" Doesn't Work

  • 15 September 2021
  • 8 replies
  • 99 views

Badge +1

Hello everyone.

 

This is frustrating. I have been trying to apply for a free education account, everything is filled-up, but the button is not responsive. I am just stuck on the page. I tried refreshing, doing it all over and over, and I even tried a different computer for this but to no avail.

Kind of getting lost on what is wrong since I have been trying to apply for a week already.

 

Hope someone can help with this error.

 

Thank you.


8 replies

Badge +1

Hi again, Robert.

 

I am not sure what is wrong. I already tried all your suggestions and tried it again to verify:

 

  • Different browser 
    • Chrome and Edge
  • Private and incognito mode
    • Chrome and Edge
  • Different computer
    • PC and Mac
    • Chrome
  • Different device
    • Phone Android
  • No VPN

 

Thank you Robert for being patient.

Userlevel 7
Badge +16

Perhaps it is one or both of your attachments that are causing the issue.

As a test, can you try attaching the following PDF and submitting?

Also, are your attachments less than 20 MB?

Here is the form that was testing from:

https://miro.com/contact/education/

Badge +1

Hi Robert,

 

Yup! That’s the form I am trying to send. I already tried again with the link you sent just to verify. 

 

My PDF file is less than 20MB. Its only 330kb. I also tried further reducing it. I also tried converting it different files: PNG, JPEG and back to PDF-- again trying which one will work but still nothing.

 

I also tried using different internet source.

 

I am not sure which one is causing the problem since when I click, literally nothing happens. 

 

Thanks, Robert.

Userlevel 7
Badge +16

And every form filed is filled out and there is absolutely no red text anywhere on the form after you click Submit?

Perhaps you can have someone else complete the form for you? If you want, I can PM you my email address and you can email email the info and attachments. Let me know. 

Userlevel 7
Badge +16

One last test, what happens if you open the form in an Incognito window and immediately click Submit without filling out any fields?

You should see all red:

 

Userlevel 7
Badge +16

@desigr - When you click Submit and nothing happens, if you scroll up the page, are any fields highlighted with red text? For example, you cannot use Gmail to apply for a Miro Education Plan:

 

Badge +1

Hi Robert!

Sadly, there are no indicators of certain errors - no highlighted with red text or anything signifying that needs to be fixed.

Out of frustration, I tried gmail and I also tried my edu email as a trial and error; however, both doesn’t work. The button isn’t responsive. When I click on “Submit”, nothing happens.

:(

 

Userlevel 7
Badge +16

@desigr - I just submitted a test application from Chrome on my android phone with no issues.

Have you tried

- a different browser

- private/Incognito mode, which should disable all extensions (a likely culprit in this case)

- a different computer/phone

- disabling a VPN if you're using one

Reply