[RESOLVED] An issue with logging in on desktop app with Google account


I can’t log in with google account on Mac app. When I enter my google account, I get an error: 

“Couldn't sign you in. This browser or app may not be secure.

Try using a different browser. If you’re already using a supported browser, you can refresh your screen and try again to sign in.”

 

 

Marina 6 months ago

Hello everyone,

The issue with Google Authorization in the Miro Desktop App was fixed in version 0.4.8. The application should notify you about the update, or you can manually download the latest version here

Could you please check if you can successfully authorize via Google OAuth now? 

 

Important: if you use two-factor authentication, the issue might still be there. The development team is on the case as well. At this time I don't have an estimated release date but we will let you know when we receive more information. As a workaround, we suggest using Miro in a browser until the fix is complete as within the browser you should be able to log in with SSO and two-factor authentication without any issues.

View original

36 replies

Hi Andrew,
This is a known issue at the moment, and we are working to fix it. We will keep you updated!

For now, you can log in with usual credentials - login + password (reset the password if you don’t have it).

Have the same problem with Windows app ((

Are you guys still working on this problem? Its been a month. This is very frustrating. This should be very easy to fix.

Hi all! For issues like this, the best option is to reach out to the Support Team at support@miro.com. Support agents will update you as soon as the issue is resolved. I’m afraid, community is helpless in resolving technical issues on Miro side :disappointed: 

Hi Marina, 

But you said one month ago "This is a known issue at the moment, and we are working to fix it."  so are you lying us if it's not why you didn't tell us to to email support@miro.com  this is very bad because your wasted your time. 

I’m so sorry, @ryakisr. I checked with the Support team that the issue is still open, and that’s why advised to reach out to support directly. As soon as the issue is fixed I will definitely update this thread for visibility, but no news for now :pensive:

This is an issue with Google’s more stringent authentication requirements for desktop/native apps.

Miro needs to adopt a different authentication flow that allows the user to complete authentication in their browser. Trello had to do the same thing. 

This authorization flow is similar to the one used for web server applications. The main difference is that installed apps must open the system browser and supply a local redirect URI to handle responses from Google's authorization server.

Hey @Andrew Kretinin, @Irina SPb, @ryakisr

The tech team said that this issue has been fixed. Could you please check if Google authentication works in the desktop app for you?   

Ah… close but not quite: 

 

 

@Chris

Thank you for the screenshots! The matter is that our app supports only basic two-factor authentication - SMS or Google authenticator. It doesn’t support a USB key.

Hey @Andrew Kretinin@Irina SPb@ryakisr

The tech team said that this issue has been fixed. Could you please check if Google authentication works in the desktop app for you?   

@Marina It is working for me. Thanks. 

Hey @Andrew Kretinin@Irina SPb@ryakisr

The tech team said that this issue has been fixed. Could you please check if Google authentication works in the desktop app for you?   

It’s not working for me. I did reinstall the Mac OS app (today). How can I fix this? It was not an issue a month ago for me. 

 

 

Have the same issue with login via google account

 

I've tried basic recommendations but the issue still actual. 

Hi @Dmitriy Chuklay,

Sorry to hear this :( We don’t have more reports about this issue, so could you please reach out to the Support team directly so that they check your case? 

Have the same issue with login via google account

 

I've tried basic recommendations but the issue still actual. 

I have the same issue. Cannot install the Windows 10 app with Google Credentials.

Same here: 

Webapp login works fine.

I am able to login through my Google Personal Account SSO in Chrome Web and on iOS app for my iPad. But unable to login into my Mac App. Throws the above message. Something I need to do here?

Hi there,

Sorry to hear this issue has happened to all of you! The team is already aware of the case, and we do our best to fix it. I will keep you posted here

Hi All,

 

I think most of you guys created your account using “sign-in with Google” option. 

 

If that is the case, then a simple workaround is to tap “forgot password” on the sign-in page and a link to recover your password will be sent to your mail.

 

And now you simply create a new password and then login with new password and not ‘directly’ as you did earlier.

 

This has worked for me, maybe will work for you too.

 

Have a great day you all.

 

Hi @Jonas Kamber @Dmitriy Chuklay @Søren Dalsberg @Jens Oliver Doleschal @Amarsh Vutukuri @ASEEM MAHAJAN

Good news! The team has fixed this issue, and now you should be able to log in with your Google account. Can you please check and confirm if it is working for you? 

nope...

I’m seeing the same problem with the OS X desktop client. I was hoping to recommend Miro to my company, but this sort of long-running, unresolved bug is a concerning example...

I am able to login through my Google Personal Account SSO in Chrome Web and on iOS app for my iPad. But unable to login into my Mac App. Throws the above message. Something I need to do here?

Solution??

 

I am getting the same error at the moment on Windows desktop app … is there a fix?

Same error 

Reply