No option for public sharing via link

  • 22 October 2020
  • 5 replies
  • 240 views

I just signed up for a Team plan and wanted to share a board via public links. However, I couldn’t find an option to do so. Below is what I see when I click on “share”

 

This is what the guide show (https://help.miro.com/hc/en-us/articles/360017730813-Sharing-Boards-and-Inviting-Collaborators): 

 


5 replies

Userlevel 7
Badge +6

@Lucy Xiao-Vance - My initial thoughts are that this was a random ‘glitch’. I would suggest signing out and back out to see if that fixes it, and maybe even from a private/incognito browser window.

If that doesn’t work, please reach out to the Miro Customer Support team directly by creating a ticket via this special form. It it does end up being related to a bug/issues, it would appreciated if you could come back here and let the community know what the Support team told you.

Honestly, I have seen numerous future enhancements pop up in produce as of late.

Userlevel 7
Badge +6

And even the guide you referenced is out of date as the Share modal should always have the Copy board link button:

 

Similar or same isssue, don’t see any options for link sharing but I know I have seen it before. 
Logged out & in, no change.
 

 

Userlevel 7
Badge +5

@PhilipMea -

Depending on what plan you are on, your Miro Company Admin might have disabled the option to enable public sharing of boards (see below):

Kiron

I opened a support ticket asking the same question yesterday but haven’t heard back yet :( 

Reply