Question

Microsoft Edge redirecting from board URL to Login Page

  • 21 June 2021
  • 7 replies
  • 235 views

Hi there. We have that problem since a few weeks that Microsoft Edge users cannot access boards that are shared via URL (neither read or edit). It appears that the Edge browser redirects them based on an Edge User Profile to the Miro login page. Most users we share a board via URL don’t have a Miro user and therefore cannot login. It’s a dead end.

The issue can be resolved by selecting “browse as guest” in edge or using a different browser all together. Unfortunately many users don’t know that und therefor a lot of workshops fail at the start moment as the participants either don’t know what to do, are not able to select “browse as guest” and cannot quickly install a different browser while its workshop time.

My question is. Is there a setting in edge where the user can prevent the redirect only for that domain? Can someone explain to me why Edge thinks it is necessary to redirect the user although they don’t have a Miro account and how this can be prevented in the future?

I am a safari - I cannot test it myself but I can check with some people in our company that use a windows machine.


7 replies

Userlevel 7
Badge +6

@Mathias Knittel 

Microsoft Edge users cannot access boards that are shared via URL

I use Microsoft Edge and can browse “anyone with the link”/public Miro boards with no issues.

I think we need to know more about these “users”.

Do they all work for the same company? If so,

  • Does their company have a paid Miro plan? If so, which one? If they are on the Business or Enterprise Plan, that could be affecting them.
  • Are these users all working from the same company and therefore could all be on the same network/VPN?
  • Their IT department could have managed browser extensions installed or policies enforced.

Some other questions/thoughts...

The boards:

How are the boards configured? As Anyone with the link → Can edit?

Is there a password on the board? If so, in the past, some users have been thrown off by a “Sign up to Miro” link on the first screen they see:

Have you connected with a user via a screen share, e.g., Zoom, to see exactly what is happening?

Userlevel 7
Badge +6

@Mathias Knittel - I am on Windows 10 64-bit with Microsoft Edge version 91.0.864.54 (Official build) (64-bit).

I have residential Internet with no VPN and am the administrator of my laptop. If you want me to try opening a test board, PM me a link.

If it works for me, then it is likely something to do with the group of users environment (MS Edge policies, network, Miro SSO applied to their domain, etc.). If this is the case, you’ll likely need to resort to advising that they, “open a Microsoft Edge InPrivate window using Ctrl+Shift+N shortcut and paste the URL into the address bar at the top”.

Userlevel 5

Hi @Mathias Knittel and @Robert Johnson  I had this exact issue with an MS Edge user being diverted to a log in page today. It was during a demo for a potential client, and it may well have lost me the contract since the demo was completely derailed!

Have either of you (or anyone else!) settled on a practical workaround for this?

Userlevel 7
Badge +6

@Alan Heckman - I have never had this issue in MS Edge. When you were diverted to the sign in page, could you sign in?
Were you using trying to open the Miro board from within another application, e.g., MS Teams, Zoom, etc.?

Userlevel 7
Badge +6

@Alan Heckman - You may want to open a Miro support ticket:

https://help.miro.com/hc/en-us/search?utf8=%E2%9C%93&query=how+to+contact+miro+support

 

You should also be able to get to the support form from your dashboard/within a board as follows:

 

Userlevel 5

@Robert Johnson thanks for your help. I have also had many workshop participants over the last year successfully reach  boards using Microsoft Edge, although Chrome has often been better or more stable. In this case two people tried join the demob board, both from the same organisation and both using Edge. The board settings were One succeeded instantly as expected, on two different devices, and the other ran into the issue described above by @Mathias Knittel. Both followed a link from a MS teams meeting chat. The user with the problem was redirected to this Miro sign in screen:

As far as she recalls she doesn’t have a Miro account, although other people in her organisation do have them. Attempting to log with her work email and password was unsuccessful. She said she also tried accessing the board in an InPrivate window but I am unsure if she actually did that. She may have been using an organisational VPN, and she may have other settings on her computer or internet connection that I don’t understand and can’t eliminate. 

I have opened the same link myself using Edge with no problems.

The demo was pretty derailed at this point, so I moved on to demoing using a screen share, rather than asking her to attempt another browser.

I will certainly be grateful if anyone can unpick this problem.

Userlevel 7
Badge +6

@Alan Heckman - Have you opened a Miro support ticket? Perhaps the support team would have this documented as a known issue and would be able to suggest a tip/workaround.

Reply