Question

Board stops working - big pdf file

  • 25 June 2021
  • 5 replies
  • 60 views

Badge +2

Hey guys,

 

I have a miro Board with some big cad-drawings. They have been put on the board as pdf files. They are around 16MB.

If I zoom to those files, the board stops working. The Image is fine but you can’t move somewhere else. I am reloading the page to get started again.

Is there any Idea what to do?

I am using firefox, Dell XPS 15-32GB RAM, NVIDA GTX1650+Intel UHD 630

Many greeting from germany
Jan

PS: link to board https://miro.com/app/board/o9J_l9LURsU=/


5 replies

Userlevel 7
Badge +14

@Jan Wegner -

I tried out your board, zooming into the different images (FYI - you might want to create frames around each so that it is easy for folks to navigate quickly from one to the other using the Frames panel). 

I zoomed all the way in to 400% and zoomed out as well.

While it was slow and did lag on occasion, it never “froze”. I am using Google Chrome on a Windows 10 laptop that is fairly underpowered compared with your setup.

A couple of thoughts:

  1. Can you try with Google Chrome?
  2. Can you try with the Miro desktop app?

The main culprit is likely the resolution of these images. If you can reduce the resolution without losing the fine details, and re-upload them, that might help.

Kiron

Badge +2

Hey Kiron,

thx for your reply. I did try with chrome and the miro-app. Best ist the app. Chrome is better than firefox but just a little. (my system is W10)

It is funny, that somehow my students do not have this problem. I even found out a pdf size A0 is difficult (700kB). The same file A4 - no problem.

I have changed the app for viewing pdf (wich was MS edge) I hope that helps.

Greetings
Jan

PS: I am using trackpad or touchpad. On this system there is no mouse.

Userlevel 7
Badge +16

@Jan Wegner - There are a number of terms being used here - “stops working” and “froze”. I’ll throw in another: “unresponsive”.

I tried on my person Dell Inspirion and my brand new, beefier Latitude. I tried on Edge, Chrome, Firefox, and the Miro desktop app, all on Windows 64-bit - and in all cases, the memory of the applications doubles - even tripled.

 

It looks like you uploaded the 7-page PDF once and used Miro’s “extract all pages” feature. One thing to not here is that, while each page the PDF is displayed, each of the newly extracted PDFs is actually the entire 7-page/16MB file.

As @Kiron Bondale suggested, you will likely want to extract the pages out side of Miro (and at a lower quality) and then upload them to the board. More work for you, but a better user experience for the board participants. If you want the full quality PDF available for download, you may even want to zip it and upload the zip to the board, or share a link to it on a 3rd-party file sharing service (Google Drive, Dropbox, etc.).

For all readers, check of the Supported File Formats Help Center article for more info on file formats, size, resolution, etc.

Badge +2

Hey @Robert Johnson - thx for your reply. It is hard to describe what is happening. Thx for your suggestion.

The page is created buy a student. It is funny that while he presented the page he could show it without problems while I stuck. I guess my system is better than his that's why I wondered. I may optimize the page or find the solution for my system which I would prefer.

I mentioned that under the marked pdf there is the same pdf what may cause trouble as well.

On the same page I added the A3 - A4 topic

​The difference between those pdf is the amount of time and zoom needed to get the pdf clearly displayed. 

Greetings
Jan

Badge +2

Hey guys,

I am still working oh that topic. Even boards with just one big pdf “getting slow”.

As mentioned my system got two graphic cards: NVIDA GTX1650+Intel UHD 630

The internal UHD 630 is working a lot during a zoom meeting with miro. Therefore I activated the GTX1650. This seems to produce some problems. In the NVIDA System I switched the miro app and adobe acrobat to the internal graphik card. Now it is a little better.

Greetings Jan

Reply