Is there a way to incorporate spreadsheet into miro?


I want to use miro as a very simple “Matlab simulink -type “ application  where I can sketch up simple flow chart and attach some simple math formula to it. Is there a way to do this?


10 replies

Userlevel 7

Hi @joey garcia,

You can try Google Drive integration for this. It allows you to embed Google spreadsheets to Miro and work with them right on the board. Does it work for you?

When I try that, Google says “This version of Google Chrome is no longer supported.  Please upgrade..."

Userlevel 6

When I try that, Google says “This version of Google Chrome is no longer supported.  Please upgrade..."

@Sean Kelleher - This is working fine for me using the latest version of the Google Chrome browser (Version 85.0.4183.102 (Official Build) (64-bit)) on Windows 10 Home (2004).

What version of

  1. Google Chrome are you using and
  2. which operating system (Windows, macOS, Linux, etc.)?

To get your version quickly, copy-and-paste the following into Chrome’s address bar and press enter:

chrome://settings/help

E.g.: Version 85.0.4183.102 (Official Build) (64-bit)

 

My Chrome says the same as yours.  

But I wasn’t using it in Chrome, I was using the Miro Windows App

Userlevel 6

 

@Sean Kelleher - Which installation type and version of the Windows app do you have?

There are the following Windows app types:

  1. Windows 32-bit desktop app
  2. Windows 64-bit desktop app
  3. Microsoft Store Miro app

I am using the Windows 64-bit flavor, version number 0.3.38:

 

While I am appear to be able to create the Google Drive embedded doc/sheet using a desktop app, it is not possible to open the embedded doc/sheet from within the desktop app itself. I just tried from the 64-bit version and the Microsoft Store version and when I try to open the sheet, I get the following message:

Selecting Open in a new tab opens the Google Sheet in a browser tab.

I also tried with a beta version (0.4.0) and receive the same message as above, but never “This version of Google Chrome is no longer supported.  Please upgrade...”

Just an FYI that here are other differences too between the Windows desktop app and the Windows 10 app from the Microsoft Store version (see App restrictions in the Desktop App help article):

 

I’m using the version from Miro (didn’t realise there was a Store one). 0.3.38 64 bit I think.

 

I does open on mine, but with that message.

 

 

 

Userlevel 6

Thanks for the screenshot as I was going to ask you exactly at which point in the process you were receiving the message and where it was displaying.

First, for anyone reading who is unfamiliar with the Google Drive integration, the high-level steps to get the point where you are editing a Google Drive doc from a Miro board are:

  1. Google Drive app installed for team/plan.
  2. Authorized Miro (actually still called RealtiemeBoard when viewing your Google account's "Third-party apps with account access" security settings) to access your Google Drive account.
  3. A Google doc/sheet/etc. has been embedded into a board using the content creation toolbar → upload → Google Drive.
  4. And finally the the embedded Google doc/sheet from within the board.

From your screenshot, @Sean Kelleher, you are on step # 4. However, that is beyond me at this point is how this is evening opening for you in the app at all as when I try it from the (1) Windows desktop, (2) Windows 10 Microsoft Store app, and (3) the beta Windows desktop app, I get the following message of Oops! This feature is not available in the embedded document. Please reload the document to edit it, or close to cancel.

 

A question for you: Although you are getting the message:

… are you still able to edit the Google Sheet?

 

Perhaps Miro is in the middle of making changes and either one or both of us are experiencing a bug. Therefore, I suggest that you submit a Submit a request – Miro Support & Help Center ticket and included a link to this Community forum post and we’ll see who’s buggier - you or me :wink:

And if you would rather I submit a ticket, just let me know and I will kindly do so.

Not sure if it’s relevant, because I was just playing around to see if the feature did what I want or not, but my Sheets file is just a playground one and therefore I made it editable by anyone with the link, instead of fiddling around working out how to authorise Miro.

Userlevel 6

Good call - I knew there was something about your Google Sheet screenshot when I saw the Sign in button at the top right. My Google Sheet was in Anyone with the link can View access, so I changed it to can Edit and now I see the following from my Miro Windows app - beta version 0.4.0:

 

However, when I load it from the stable 0.3.38, I get the same message as you:

 

I can still edit the Sheet even though I am receiving that message, however, I believe this should still be reported to Miro support in case this is a change in behavior that they are not aware of.

Reply