don't miss

Miro Developer Platform 2.0 now available!

Userlevel 4

Hi everyone!

Over the last year, we’ve been hard at work revamping our Miro Developer Platform—Focusing on your input to see how we could create a next generation tool for developers like yourselves. We’re all about finding new and innovative ways to extend the power of Miro, and today we’re excited to announce our official release of Version 2.0 of the Miro Developer Platform. 🚀


We’d like to first thank all of you for helping us test and provide feedback on our beta version the last few months, and hope you’re as excited as we are to officially launch version 2.


With a fully re-written API, SDK, and overall Platform Experience, we’re aiming to empower you and your teams to build the next big thing. When building this v2 Developer Platform, we used feedback from our developer community to guide us as we focused on scalability, reliability, and the developer experience.


Now that Version 2.0 is officially launched, we’ll be putting all of our efforts into continuing to grow and develop this Developer Platform. Unfortunately, this means that we plan to sunset the Miro Developer Platform 1.0 later this year. Make sure to visit our official migration guides to learn more about moving your existing applications to version 2.0.


We want to give you the best possible experience while using the Miro Developer Platform, so we encourage you to reach out with any questions or concerns. Feel free to post in our Community Forum or join our Developer Discord. We also have a dedicated place for you to provide feedback and request features on our Public Roadmap.

Interested in learning more? Visit our Developer Portal to start building your first Miro App.

14 replies

It seems that API v1 stopped working already - isn’t it too soon?


Sending GET request to

received status code 404 

Response body:  {

    "message": "no Route matched with those values"


<Response [404]>

Userlevel 4

Hi @truemetal ! 

V1 endpoints should definitely still work. Can you see if this is working as expected for you?


We have our official deprecation policy listed here:

It works now - seems it was a temporary glitch, thanks!

Hello @Addison Schultz ,

is this post to be understood as the deprecation announcement for the V1?

Our team’s API requests are intermittently hitting the following error starting today:


ERROR: The request could not be satisfied

The request could not be satisfied.
Bad request.

We can't connect to the server for this app or website at this time. There might be too much traffic or a configuration error. Try again later, or contact the app or website owner.

If you provide content to customers through CloudFront, you can find steps to troubleshoot and help prevent this error by reviewing the CloudFront documentation.

Generated by cloudfront (CloudFront)
Request ID:



My problem above came from passing a “json” keyword parameter with an empty {} along with my GET requests. This wasn’t an issue before today, but removing that solved it, in case anyone else has something similar.

Userlevel 4

Hi @oliverir! With the launch of the new platform, we do have an official deprecation policy regarding V1. 

You can find all the details here:

Userlevel 4

Hi @MiroMonkey ,


Thanks for the report, and for debugging this issue a bit! I’m happy you got this fixed—I’ll pass this over to the team

Hi @Addison Schultz !

Thank you, I looked at the page. It says there

[...] Miro will provide a minimum of 6 months' notice before retiring a service. This 6 month period will begin with a “deprecation announcement” that communicates our intention to retire a service on a given future date.

What I am wondering though is if this transitory deprecation period has already been entered! My team and I definitely need to adjust to the changes but aren’t quite sure yet how quickly we need to act. Can we expect an “official” deprecation announcement or is this it?

Userlevel 4

Hey @oliverir,


You should have received our official deprecation notice via email! We sent it a few weeks ago. Can you check to see if you have an email with the subject that contains “Miro Developer Platform News”?

Hey @Addison Schultz,

sadly I have only recently activated the notifications for my account, so I doubt I would have received such an email. But your reply answers my question regardless, thank you for your help, sir!

We have just finished building a V1 app and I was creating another app registration for it. When we try to launch the app, it fails to load and I get errors like, “This tool is unavailable on this board” and in the console, “Uncaught Error: HELLO_APP_FROM_IFRAME:: PluginController not found for origin...”. Does anyone have any idea why this might happen?

Userlevel 4

@Jim Garlick, Can you explain a bit more by what you mean with creating another app registration? Are you creating a new Miro app?

Yes. We needed to re-create one of our V1 apps because we changed from non-expiring Access Tokens to using Refresh Tokens. The code is identical to before, but the app isn’t launching in the Board.