[RESOLVED] Getting "400. That’s an error" when trying to use Google Drive


I’m getting an error as I try to use Google Drive as well. My error says “400. That’s an error. The server cannot process the request because it is malformed. It should not be retried. That’s all we know.” I’ve done all of the things suggested above. I’m using fiber optic internet connection, so it’s quite fast. 

 

Is there anything else you can suggest-- is this a “known issue”?

Alyona 1 month ago

Hi @Mark Vincent, @Gwenno Hughes, @Maciej Kowalczyk, @Tim Bodewes,

The fix for the bug with Google Drive has been live for several days already; I'm sorry about updating you only now. Please let me know if any of you are still facing issues with adding files from Google Drive!

View original

16 replies

That did help. Thanks!

Userlevel 5
Badge +1

Hi @Hayley English, @Solanin, @Scott Key,

The 400 error is caused in most cases by insufficient access permissions. Therefore, the first step is always to ensure that these checkboxes are ticked: 

To get to this page, you need to remove access to Miro App in your Google account security settings first (here's the direct link to the settings) and then reauthorize the Google Drive integration again on the Miro side.

Please complete these steps and let us know if you're getting the error still. If you do, when do you see it? Is it during the app's autorization, when you're trying to add a file from GDrive or at some other moment?

This most recent suggestion to logout and reconnect from the profile works. I was trying to do it from a board, and the redirect there was giving me the 400 error.

Same the work around didn’t work

Hello,

 

same here. Getting ERROR 400 all the time. I tried to reinstall app and it does not work.

 

Best regards,

Maciek

Same here. The workaround does not work either. 

Best, Tim
 

Userlevel 5
Badge +1

Hey @Maciej Kowalczyk, @Tim Bodewes,

Thanks for letting us know! If the previous workaround doesn't work, you can also remove access to Miro App in your Google account security settings (here's the direct link to the settings)
and then reauthorize the Google Drive integration again on the Miro side.

If you have a personal Google account, the following additional checkboxes should be checked on the consent screen for the correct work of the integration: 

 

Please let me know how it goes!

This error is happening still for me as well.

@Alyona 
The weird thing is after following the step and adding the Drive integration trough this method, i don’t get google right pop up ( am i doing it right ?)
 

After Clicking on get app i end up directly on my mirro home page.
and when i check the App & integration google drive is installed:
 


With a little pop up “ google drive has been installed, but i don’t have the google authorization Pop up page that you are showing. What am i missing ?

The third-Party apps with account access in google don’t show Miro:
 


 

Userlevel 5
Badge +1

Hi @Solanin,

I can see on your screenshot that you're working in the desktop app. Could you try completing the google drive installation and authorization in a browser? 

Also, this screenshot is from the team's integrations settings:

While we were suggesting re-connecting (or connecting, in your case) in the profile settings:

connect_Google_Drive.jpg

Could you please try authorization there (still in the browser) instead? 

Hmm ok i’m dumb, i didn’t think that would be a difference between the app  integration section, and the integration profile section. Disconnect/reconnect did the trick.

Thank you very much. 

Userlevel 5
Badge +1

No worries, @Solanin!

It can be confusing; the titles are the same, after all. Glad to hear the issue is fixed for you 👍

Userlevel 5
Badge +1

Hi @Mark Vincent, @Gwenno Hughes, @Maciej Kowalczyk, @Tim Bodewes,

The fix for the bug with Google Drive has been live for several days already; I'm sorry about updating you only now. Please let me know if any of you are still facing issues with adding files from Google Drive!

I’m experiencing this issue and have tried the above recommendations. Any advice?

 

I’m also getting this issue, as described by @Mark Vincent, and have been over the last few days.

 

Any news?

Userlevel 5
Badge +1

Hey @Mark Vincent@Gwenno Hughes,

Thanks for letting us know about the issue you're running into. I've moved your reports to a new topic as they are about a different error with a different root cause. I’m afraid there’s currently a bug that is causing this error when authorizing in Google Drive. The good news is that the team is aware of the issue and is already on it. We’ll keep you posted so please stay tuned!

 

In the meantime, feel free to use the following workaround: go to your profile settings -> Integrations page and reconnect the Google Drive integration:

connect_Google_Drive.jpg

Reply