Move an object on Mac

  • 14 January 2022
  • 4 replies
  • 24 views

Hi

I have an excessive amount of time trying to move a simple text box in MIro.  I can grab the box with no issue but actually moving it to where I want to on the board is impossible.  What am I doing wrong?


4 replies

Userlevel 7
Badge +6

@Lynn Franz - Can you tell us more about your setup?

Are you using a mouse or trackpad?

What is your Miro board navigation set to?

Are you using Miro with a browser, if so, which one?

Or the Miro desktop app?

Can you share a video of what is happening? Loom is free and quite easy to use and share a video.

My team and I have been having this and related issues all week. 

When I select a frame or an area of the board, 2 things have been happening that were not happening before the intro of the right click dragging (perhaps a cooincidence but problems we are experiencing are related to dragging/moving stuff around).

  1. Selecting seems to be SUPER sensitive or something. We are having a LOT of trouble selecting items on a frame without getting a bunch of other items that are close by but not THAT close by; and
  2. I can NOT move frames/content that I have selected. There is a big lag, then a diagonal blue line appears, and then the frame + content goes shooting along the blue line to some random spot.

Today I selected a frame and its content, couldn’t move it, it slide along the random blue (guide?)line that appeared and dropped on top of another very complex frame. The undo function was not available! I tried control Z; the undo/redo arrows were not available on the board. Then because of the SUPER senstive selection and the complexity of the content on the frames, I couldn’t pick it up to (try to) move it back because it was selective anything and everything around it. I ended up restoring the version from yesterday rather than spends hours moving parts back individually. 

Any body know what’s going on? It has happened using a mouse and a trackpad. Using Miro on Chrome.

Thanks in advance for any advice!

Userlevel 7
Badge +6

@Lara Trehearne - Re #1: Doing a long mouse button press/touchscreen tap until the cursor turns into a crosshair will then only select objects that are fully encased by the blue selection box - more on this here:

https://community.miro.com/ask-the-community-45/is-anyone-else-struggling-with-the-changes-to-the-select-functionality-6788?postid=28803#post28803

This was a change with the new/improved(?) navigation options of left-click select/right-click pan. However, they should have left the old behaviour as the default, with the long-press activating the “selection line grabs everything”.

#2 - From the behaviour you are describing, you are holding Shift while dragging objects - e.g.:
Example - at first I am holding down the Shift key while dragging the objects, then I depress the Shift key:

 

This may be another change introduced by Miro as I only remember this Shift+drag behviour of snapping objects at 45 degrees when moving Connection Lines.

@Robert Johnson thank you so much for your reply! You were right about my shift-select behaviour – which I noticed later – which I think I had been doing to switch between the hand and arrow cursors.  It is built into my muscle memory from somewhere! 
I love the right click to drag change but agree with your comments about the default and your ?. Not loving the rest so far. 

Reply