[KNOWN BUG] Can't disable grid in frames

  • 30 December 2021
  • 10 replies
  • 115 views

From what I understand the grid mode will be deprecated soon. However, when I create new frames on my board now the grid mode is automatically applied and I cannot disable it as the other button is grayed out. It’s confusing. How can I disable grid mode?

When I try to move any elements within the frame they are automatically distributed in a grid

Robert Johnson 5 months ago

Another update from Miro support:

I'm happy to inform you that our technical team just confirmed that a fix for this has just been released!

It should now not be possible anymore to create new grid frames unless you copy existing ones. 

I have tried again in latest Chrome and Miro desktop app and the bug is still present - when clicking on an old frame with Grid mode present, then pressing F to create a new frame, the new frame has Grid mode.

I had cleared the cache (and reset application data) and signed out and back in to my Miro account.

View original

10 replies

Userlevel 7
Badge +10

Another update from Miro support:

I'm happy to inform you that our technical team just confirmed that a fix for this has just been released!

It should now not be possible anymore to create new grid frames unless you copy existing ones. 

I have tried again in latest Chrome and Miro desktop app and the bug is still present - when clicking on an old frame with Grid mode present, then pressing F to create a new frame, the new frame has Grid mode.

I had cleared the cache (and reset application data) and signed out and back in to my Miro account.

Userlevel 7
Badge +10

Update #2 from Miro support:

First of all, I'd like to thank you for your patience!

While the issue hasn't been resolved I just wanted to provide you with an update from our technical team who now confirmed that they're working on it and will provide us with an update as soon as they can.

Once again, thank you for your patience!

Userlevel 7
Badge +10

Miro recently removed grid mode without warning. You will need to create a new frame. 

More on this here:

https://community.miro.com/ask-the-community-45/sticky-notes-stuck-in-a-grid-mode-4772

The problem is that instead of the grid mode being removed on my frames, it is forced and I cannot remove it on new frames I create. Basically, I cannot switch to freeform mode

Isn’t it supposed to be the other way around where only freeform mode is available or am I misunderstanding?

Userlevel 7
Badge +10

@Daria - I found an old board with a Frame with Grid mode enabled before Miro’s decision to deprecate Grid mode. When I hover over Grid/Freeform mode, I see:

The Learn more link is to:

https://help.miro.com/hc/en-us/articles/360018261813-Frames#h_01EH73VR7P7YDC7057T4A38A5N

Which states:

 

If I create a new frame, I no longer have the Grid/Freeform options:

 

But if I duplicate/copy-paste an old frame, the options are still present.

I cannot remove it on new frames I create

Are you able to record a video of you creating a new frame with Grid/Freeform modes available? Loom is free, easy to use, and easy to share videos.

I think I have found a weird bug, to be honest. 

My old frames no longer have the grid setting. But I’m not sure how, but this morning when I was creating new frames, all frames had the grid setting locked by default without a way to disable it.

So when I select a frame that has new settings (with no grid) - when I create a new frame it has the same no-grid options.

But if I select a frame that has that locked grid setting, then the new frame I create has this setting and it cannot be removed.

Here is the video showing the issue

 

Userlevel 7
Badge +10

@Daria - Good catch!

I believe the behaviour is intentional where a newly created object’s properties are inherited from the last selected object of the same type - an example of this could be a Text box - if I create a text box and make the text red and give it a yellow background, when I create a new text box right after just having selected my formatted text box, the new one would have red text with yellow highlighting.

With that in mind, here is another example of what you have found - here is a board with one frame with Grid mode enabled that I copied from an old board.

Test pre-conditions:

  1. Created a new board
  2. Copy-pasted a frame with Grid mode enabled on this board.
  3. Closed the new board.

Then, I

  1. Opened the board
  2. Created a new frame - no Grid mode option
  3. Selected the existing frame that had Grid mode enabled
  4. Created a new frame

Result: Grid mode option present.

 

I will open a Miro support ticket - hopefully they will forward this to the product team.

@Daria - I will CC you on the ticket.

Userlevel 7
Badge +10

Sharing the support team’s first response:

Thanks very much for reaching out to the Miro support team!

I can see that you have been discussing this issue in great detail and with a lot of helpful material in our Community - thank you for all the work you have put into this!

I have indeed reached out to our product team asking for their advice in order to be able to give you a reliable answer. 

Once I hear back from them, I will update you! Should any questions come up in the meantime, please feel free to drop us a line at any time.

Userlevel 7
Badge +10

Update #1 from Miro support:

Eva here from the support team with a quick update: our product team believes that this is most likely down to a bug.

Unfortunately, they won't be able to fix it before 10 January. We are truly sorry for the inconvenience this is causing you and thank you for your patience!

As soon as we have another update on this we will let you know. 

Userlevel 7
Badge +10

Final update from Miro support:

Hi again Robert and Daria, 

I have another and final update from our tech team for you: the root cause for the buggy behaviour is that if you select a frame in grid mode before creating a new one then the new frame will be created in grid mode as well.

Thankfully, there is a simple workaround - which is not to select a frame in grid mode before creating a new frame.

However, they also confirmed that they are currently working on fixing this issue so that the workaround won't be necessary anymore very soon in the future. 

We'd like to thank you for your valuable feedback - this is what helps us identify any issues our users are facing and improve our product!

Reply