Is Miro broken today?

  • 5 August 2022
  • 9 replies

When I launched my board today all stacked elements have reflowed.

I have a rectangle with a few text elements and some other rectangles layered over it and a table full of content next to that. Today, all of those elements are reflowing across my board and causing the frame to expand significantly.

I’ve tried repositioning the elements, but they just cause the reflow to change sort order. Stacking isn’t possible.

I usually work in the Mac desktop wrapper, which I updated, but I also tried in-browser (Chrome variant). My board is literally useless right now.

9 replies

Userlevel 5

I just updated the PC desktop app, which is now hanging and inaccessible, though I’m able to access the web client via Chrome.

Userlevel 7
Badge +12

Chrome, Edge, and Firefox (64-bit) all fine for me on Windows 11.

I opened the Miro desktop app which was at 0.7.16 and as it started to update, the app hung. I killed the process, re-opened to 0.7.17 and it is working fine for me. I may be imagining things, but the panning seems a wee bit smoother now in the desktop app.

@David Holman - One of my canned responses for troubleshooting:


Here are things to try.

  • If you are using a browser to access Miro:
    • Sign out and back in (a code change may have been pushed and needs to be picked up)
    • clear the cache
    • disable all extensions (opening an incognito/private browser window usually takes care of this for you)
    • Try a different browser
    • Try the Miro desktop app
  • If using the Miro desktop app, reset the application data.

Can you try from a different device/computer?

Does it happen for any other board participants?

What happens if you duplicate the board?

Is the board shared with others? If so, what happens if you make the board private and share it again? (Only an option if you are the board owner, and the board is not in a free plan.)

If you are on a paid plan, you can also report this directly to the Miro support team - instructions can be found here →  

Seems to have something to do with this feature combined with frames. Maybe your old board didn’t have frames? I’ve never paid any attention to “grids” before so this is news to me.

Here I’m dragging a single grouped set of objects into the frame (where it lived before this “upgrade”). The result is what my board looked like when I opened it today.



I created a new frame, copied all my content to it, and it’s fine now.

Something in a recent update must have broken a setting I had on that frame. I haven’t looked at it in about a week so it may not have been today. The board itself is only a couple of months old, so it’s not like I’m asking for some kind of “early days” support.

I just noticed this when troubleshooting. I’m guessing this is the culprit in my case. Was that “boxes” button always there and I just ignored it?

This isn’t going to help my case for adopting Miro across the company 🙄



Userlevel 7
Badge +12

I don’t think Grid mode is the issue as I just opened a really old, really big board with Grid mode enabled and it loaded and functioned as expected.

Userlevel 7
Badge +12

@David Holman - Grid mode was a feature specific to Frames and would “snap” objects into alignment starting at the top of a frame and moving to the right/down. From your GIF, Grid mode looked to be enabled. Glad you got it sorted out!

Userlevel 5

Thanks for the troubleshooting points @Robert Johnson . I upgraded from 0.7.16 to 0.7.17 yesterday as well, which caused the desktop app to hang, but uninstalled / fresh reinstalled 0.7.17 this morning and things are working as expected. Appreciate the detailed and thoughtful response.

Userlevel 7
Badge +12

@Kyle Chipman - You’re welcome!

By the way, in case you did an uninstall and install again, in the future you can just reset the application data which should be sufficient 99% of the time:

From the dashboard/”Boards tab” of the desktop app:

Press Alt > Help and choose to reset the application data as shown in the screenshot below:

Resetting the app data on the Desktop app for Windows

If you cannot find the menu, you probably use the app downloaded from the MS Store. In this case, to reset the app data, open Windows Settings > Apps > Apps and Features > find Miro on the list > Advanced options Reset.